当前位置: 首页 > >

“Usage of API documented as @since 1.6+……”的解决办法

发布时间:

在使用Java脚本语言javax.script包时,项目报错,报错内容如下:


Usage of API documented as @since 1.6+ This inspection finds all usages of methods that have @since tag in their documentation. This may be useful when development is performed under newer SDK version as the target platform for production



问题解决方法:打开工程配置,修改language level为6以上的版本即可
File ->Project Structure->Project Settings -> Modules -> (需要修改的工程名称) -> Sources -> Language Level->选6以上的版本。



到这里问题已经解决了,想继续了解问题根源的同学请继续:


首先分析报错信息,这是由于使用了当前开发环境无法解析的jdk特性,javax.script是Java6中加入的新特性,可能当前开发环境版本较低。
打开工程的属性设置窗口(Ctrl+Alt+shift+S):


目前的JDK版本是1.7,这没毛病,下面的language level也是选择了和JDK版本一致的,但是为什么还会报错?接下来看下工程配置信息:


从这里可以看出工程的language level还是5.0,这也就解释了为什么使用javax.script会报错了,把这里的language level改成6以上的版本,确认后就OK了。


那么还有一个疑问,那就是我明明在项目配置中设置了language level为7,为什么到了module中就变成5了呢?


这里面就是项目和工程的区别了,在maven中每个工程有各自的pom.xml配置,如果不在pom.xml中进行配置的话,工程的language level默认为5,可以在pom中进行该项设置



org.apache.maven.plugins
maven-compiler-plugin
3.1

1.7
1.7
utf-8



友情链接: